Заставка

A. S. Chakal

Полная торговая система TURTLES

Москва

2004


Входы

Обычные трейдеры мыслят главным образом в терминах входных сигналов, когда думают об определенной торговой системе. Они полагают, что вход - самый важный аспект любой торговой системы. Они, должно быть, удивятся, обнаружив, что Черепахи использовали очень простую систему для входов, основанную на прорыве канала - вариант системы Ричарда Дончиана (Richard Donchian).

Черепахам дали правила для двух различных, но родственных прорывных систем, которые мы называли Система 1 и Система 2. Нам дали полную свободу действий в распределении наших средств между этими двумя системами. Некоторые из нас выбрали торговлю на все деньги по Системе 2, некоторые распределили свой счет между системами 50% на 50%, некоторые выбрали другие варианты.

Система 1 - Более краткосрочная система, основанная на 20-дневном прорыве
Система 2 - Более простая долгосрочная система, основанная на 55-дневном прорыве.

Прорывы

Прорыв определяется, когда цена выходит за границы high или low определенного количества дней. Таким образом, 20-дневный прорыв состоится при выходе за границы high или low предшествующих 20 дней.

Черепахи всегда торговали на прорыве, когда он происходил, в течение дня, не дожидаясь, закрытия этого дня или открытия следующего. В случае открытия с гэпом Черепахи входили в позицию на открытии, если рынок открывался с прорывом.

Вход Системы 1 - Черепахи входили в позицию, когда цена выходила на один тик за границы high или low предыдущих 20 дней. Если цена превышала 20-дневный high, то Черепахи покупали один юнит, открывая длинную позицию по соответствующему финансовому инструменту. Если цена падала на один тик ниже 20-дневного low, то Черепахи продавали один юнит, открывая короткую позицию.

Сигнал на вход Системы 1 игнорировался, если последний прорыв привел к прибыльной сделке.

ПРИМЕЧАНИЕ: Для проверки этого последний прорыв рассматривался независимо от того, произошел ли реальный вход в позицию при этом прорыве или этот прорыв был пропущен из-за этого правила. Считалось, что этот прорыв привел к убыточной сделке, если цена после прорыва прошла 2N в направлении, противоположном прорыву, до того, как произошел прибыльный 10-дневный выход. Направление последнего прорыва не имеет значения для этого правила. Таким образом, "убыточный длинный" или "убыточный короткий" прорыв позволяет войти в позицию на следующем прорыве, независимо от того будет он "длинным" или "коротким". Однако, в случае, когда прорыв был пропущен из-за того, что предыдущий прорыв был "прибыльным", вход будет сделан на 55-дневном прорыве, чтобы не пропустить большое движение.

В любой момент времени, если вы вне рынка, всегда есть некоторая цена, при достижении которой открывается короткая позиция и есть другая, более высокая цена, при которой открывается длинная позиция. Если последний прорыв был убыточным, то входной сигнал будет ближе к текущей цене (на границе 20-дневного канала), чем если бы это был прибыльный прорыв. В случае , если последний прорыв был прибыльный, то сигнал будет значительно дальше - на границе 55-дневного канала.

Вход Системы 2 - Черепахи входили в позицию, когда цена выходила на один тик за границы high или low предыдущих 55 дней. Если цена превышала 55-дневный high, то Черепахи покупали один юнит, открывая длинную позицию по соответствующему финансовому инструменту. Если цена падала на один тик ниже 55-дневного low, то Черепахи продавали один юнит, открывая короткую позицию.

Все прорывы в Системе 2 приводят к открытию позиций, вне зависимости от того, каким был предыдущий прорыв - прибыльным или нет.

Добавление юнитов

Черепахи входили в длинную позицию одним юнитом на прорыве и увеличивали размер открытой позиции после того, как цена прошла расстояние 1/2 N от начальной точки входа. Этот интервал (1/2 N) отсчитывался от реальной цены исполнения предыдущего ордера.

Так, если начальный ордер исполнен из-за проскальзывания на расстоянии 1/2 N от прорыва, то новый ордер будет на расстоянии 1N от прорыва (1/2 N от проскальзывания плюс интервал 1/2 N для добавления юнита).

Это может продолжаться до достижения максимально допустимого количества юнитов. Если рынок движется достаточно быстро, то можно добавлять максимум четыре юнита за один день.

Пример:

Золото
N = 2.50
55-дневный прорыв = 310

Первый юнит добавлен 310.00
Второй юнит 310.00 + 1/2 x 2.50 или 311.25
Третий юнит 311.25 + 1/2 x 2.50 или 312.50
Четвертый юнит 312.50 + 1/2 x 2.50 или 313.75

Сырая нефть
N = 1.20
55-дневный прорыв = 28.30

Первый юнит добавлен 28.30
Второй юнит 28.30 + 1/2 x 1.20 или 28.90
Третий юнит 28.90 + 1/2 x 1.20 или 29.50
Четвертый юнит 29.50 + 1/2 x 1.20 или 30.10

Последовательность

Черепахам было предписано строго соблюдать входные сигналы, потому что большую часть прибыли каждого года могли принести 2-3 большие прибыльные сделки. Если сигнал был упущен, это могло сильно повлиять на финансовый результат года. Черепахи с лучшими результатами торговли последовательно выполняли входные сигналы. Черепахам с худшими результатами, а также всем, кто был уволен из программы, не удалось последовательно выполнить все входы, которые предписывала система.


Выходы

Есть другая старая пословица: "Вы никогда не можете обанкротиться, получая прибыль". Черепахи не согласны с этим утверждением. Фиксация прибыли слишком рано - это одна из наиболее распространенных ошибок при торговле по трендовым системам.

Цены никогда не идут прямо вверх; необходимо позволять ценам идти против вас, если вы собираетесь проехаться на тренде. В раннем тренде это часто может означать, что 10-30-процентная прибыль может смениться небольшим убытком. В середине тренда 80-100-процентная прибыль может упасть на 30-40%. Искушение облегчить позицию, зафиксировав прибыль, может быть очень велико. Черепахи знали, что от точки фиксирования прибыли зависит прибыльность или убыточность всей торговли.
Система Черепах входит на прорывах. Большинство прорывов не заканчиваются трендом. Это означает, что большинство сделок Черепах были убыточными. Если прибыльные сделки не принесли достаточно денег, чтобы покрыть эти убытки, черепахи теряли деньги. Каждая прибыльная торговая система имеет различные оптимальные точки выхода.

Рассмотрим систему Черепах. Если вы вышли из сделки с прибылью 1N, в то время как вы выходите из убыточных позиций с убытком 2N, то вам нужно в два раза больше прибыльных сделок, чтобы покрыть убытки от проигрышных сделок. Существует сложная зависимость между компонентами торговой системы. Это означает, что вы не можете рассматривать правильный выход из прибыльной позиции без рассмотрения входа, управления капиталом и других факторов. Правильный выход из прибыльной позиции - один из главнейших аспектов торговли и менее всего ценимый по достоинству.

Выходы Черепах

Выход Системы 1 - 10-дневный low для длинных позиций и 10-дневный high для коротких. Все юниты выводились из рынка, если цена шла против открытой позиции к 10-дневному прорыву.

Выход Системы 2 - 20-дневный low для длинных позиций и 20-дневный high для коротких. Все юниты выводились из рынка, если цена шла против открытой позиции к 20-дневному прорыву.

Как и в случае со входами, Черепахи обычно не размещеали стоп-ордеров, а вместо этого следили за ценой в течение дня и выходили из позиции, как только происходил прорыв.

Эти выходы трудные. Для большинства трейдеров выходы системы Черепах были, вероятно, единственной сложной частью правил системы Черепах. Ожидание 10- или 20-дневного low могло часто означать наблюдение как улетучивается 20%, 40% и даже 100% достигнутой прибыли. Есть очень сильное желание выйти пораньше. Нужна большая дисциплина, чтобы наблюдая, как ваша прибыль улетучивается, удержаться в позиции для того, чтобы поймать действительно большое движение. Способность придерживаться дисциплины и строго выполнять правила - это отличительная черта опытного успешного трейдера.


Полная торговая система TURTLES.

Большинство трейдеров используют механическую торговую систему (МТС). И это не случайно. Хорошая МТС автоматизирует весь процесс торговли. Такая система дает ответы на все вопросы, возникающие перед трейдером во время торговли. Система облегчает трейдеру последовательную торговлю, потому что есть набор правил, точно определяющих, что нужно делать. Механика торговли не оставляет трейдеру места для рассуждений. Если вы знаете, что ваша система зарабатывает деньги на длительном временном промежутке, то проще принимать сигналы и торговать в соответствии с системой в периоды потерь. Если вы полагаетесь на ваши собственные суждения во время торговли, то может оказаться, что вы робкие как раз тогда, когда нужно быть решительными, и бесстрашны, когда нужно быть осторожными. Если у вас есть работающая МТС и вы ей следуете, ваша торговля будет последовательной несмотря на внутреннее эмоциональное напряжение, которое могло бы возникнуть из-за серии проигрышей или большой прибыли. Вера, последовательность и дисциплина, достигнутые тщательным тестированием МТС - это ключ к успеху трейдера. Торговая Система Черепах была полной торговой системой. Ее правила охватывали все аспекты торговли и не оставляли фактически никаких вопросов для субъективного решения трейдером. Она имела все компоненты полной торговой системы.

Компоненты полной системы

Полная система предоставляет решения всех вопросов, необходимые для успешной торговли:

· Рынки - Что покупать или продавать

· Размер позиции - Сколько покупать или продавать

· Входы - Когда покупать или продавать

· Стопы - Когда выходить из проигрышной позиции

· Выходы - Когда выходить из выигрышной позиции

· Тактика - Как покупать или продавать

Рынки - Что покупать или продавать

Первое решение - что покупать или продавать, т.е. на каких рынках торговать. Если вы торгуете на небольшом количестве рынков, то вы сильно сокращаете свои шансы попасть в тренд. В то же время вы не хотите торговать на рынках с слишком низким оборотом и на нетрендовых рынках.

Размер позиции - Сколько покупать или продавать

Решение о том, сколько покупать или продавать - безусловно самое главное, однако это часто неправильно понимается трейдерами. Решение о том, сколько покупать или продавать влияет и на диверсификацию, и на управление капиталом. Диверсификация - это попытка распределить риск по многим финансовым инструментам и увеличить возможности для проведения успешных сделок. Для правильной диверсификации нужно делать похожие, если не идентичные, ставки по многим различным инструментам.
Управление капиталом имеет дело с ограничением ставок таким образом, чтобы у вас не закончились деньги до того, как возникнут хорошие тренды.
Сколько покупать или продавать - это единственный важнейший аспект торговли. Большинство начинающий трейдеров рискуют слишком многим на каждой сделке и сильно увеличивают свои шансы обанкротиться, даже придерживаясь в остальном правильного стиля торговли.

Входы - Когда покупать или продавать

Решение о том, когда покупать или продавать, часто называют решением о входе. Автоматические системы генерируют входные сигналы, которые определяют точную цену и рыночные условия для входа на рынок.

Стопы - Когда выходить из проигрышной позиции

Трейдеры, которые не урезают свои потери, не будут преуспевать в долгосрочной перспективе. Самая важная вещь в ограничении своих потерь - это заранее определить точку, где вы будете выходить, до того, как вы откроете позицию.

Выходы - Когда выходить из выигрышной позиции

Многие "торговые системы", которые продаются как полные торговые системы, не описывают отдельно правил выхода из выигрышной позиции. Однако вопрос когда выходить из выигрышной позиции - ключевой для прибыльности системы. Любая торговая система без описания, когда выходить из выигрышной позиции, не является полной.

Тактика - Как покупать или продавать

Как только получен сигнал, на первый план выходит тактика его исполнения. Особенно это справедливо для больших сделок, когда вход и выход из позиции может привести к неблагоприятным движениям цен или воздействию на рынок.


Размер позиции

Размер позиции - это одна из самых важных, но менее всего понимаемых компонент торговой системы. Черепахи использовали алгоритм расчета размера позиции, который был очень продвинутым для тех дней, так как он регулировал размер позиции в зависимости от волатильности рынка, выраженной в долларах. Это ознает, что данная позиция имела тенденцию к увеличению или уменьшению в данный день примерно на ту же сумму в долларовом выражении (по сравнению с позициями на других рынках), независимо от волатильности конкретного рынка.

Такая нормализация волатильности очень важна, так как это означает, что различные сделки на различных рынках имели одинаковые шансы для получения определенной суммы прибыли (или определенной суммы убытка).

Это увеличивало эффективность диверсификации торговли на различных рынках. Даже если волатильность данного рынка была низкой, любой существенный тренд приводил к значительному выигрышу, так как Черепахи имели больше контрактов по этому низковолатильному инструменту.

Волатильность - смысл N

Черепахи использовали концепцию, которую Richard Dennis и Bill Eckhardt назвали N, для представления базовой волатильности конкретного рынка.

N - это просто 20-дневная экспоненциальная скользящая средняя от Истинного Диапазона (True Range), которая сейчас более известна как ATR. Формально, N является средним дневным диапазоном движения цены конкретного рынка, с учетом гэпов при открытии. N измеряется в тех же пунктах, что и базовый контракт.

Дневной Истинный Диапазона рассчитывается по формуле:

True Range = Maximum (H-L, H-PDC, PDC-L)

где:

H - текущий High (максимальная цена дня)
L - текущий Low (минимальная цена дня)
PDC - цена вчерашнего закрытия (Previous Day's Close)

Для расчета N используйте следующую формулу:

N = (19 x PDN + TR) / 20

где:

PDN - вчерашнее N (Previous Day's N) TR - текущий дневной True Range

Поскольку эта формула требует вчерашнее значение N, вы должны начать с 20-дневного простого среднего True Range для начального расчета.

Расчет долларовой волатильности

Первым шагом в установлении размера позиции было определение долларовой волатильности рынка (Market Dollar Volatility), представленной волатильностью рыночной цены (которая определяется через N). Это звучит более сложно, чем есть на самом деле. Это определяется простой формулой:

Dollar Volatility = N x Dollars per Point

(Dollars per Point - это стоимость одного пункта движения цены в долларах)

Размер позиции с учетом волатильности

Черепахи составляли позиции из частей, которые мы называли юнитами (Unit). Величина юнита выбиралась так, чтобы 1 N представляло 1% от суммы торгового счета (Account) . Таким образом, юнит для данного рынка может быть рассчитан по следующей формуле:

Unit = (1% of Account) / (Market Dollar Volatility)

или

Unit = (1% of Account) / (N x Dollars per Point)

Пример
Heating Oil HO03H:

Рассмотрим следующие цены, True Range и значения N контракта на мазут на март 2003г.:

Дата | High | Low | Close | True Range | N
11/1/2002 | 0.7220 | 0.7124 | 0.7124 | 0.0096 | 0.0134
11/4/2002 | 0.7170 | 0.7073 | 0.7073 | 0.0097 | 0.0132
11/5/2002 | 0.7099 | 0.6923 | 0.6923 | 0.0176 | 0.0134
11/6/2002 | 0.6930 | 0.6800 | 0.6838 | 0.0130 | 0.0134
11/7/2002 | 0.6960 | 0.6736 | 0.6736 | 0.0224 | 0.0139
11/8/2002 | 0.6820 | 0.6706 | 0.6706 | 0.0114 | 0.0137
11/11/2002 | 0.6820 | 0.6710 | 0.6710 | 0.0114 | 0.0136
11/12/2002 | 0.6795 | 0.6720 | 0.6744 | 0.0085 | 0.0134
11/13/2002 | 0.6760 | 0.6550 | 0.6616 | 0.0210 | 0.0138
11/14/2002 | 0.6650 | 0.6585 | 0.6627 | 0.0065 | 0.0134
11/15/2002 | 0.6701 | 0.6620 | 0.6701 | 0.0081 | 0.0131
11/18/2002 | 0.6965 | 0.6750 | 0.6965 | 0.0264 | 0.0138
11/19/2002 | 0.7065 | 0.6944 | 0.6944 | 0.0121 | 0.0137
11/20/2002 | 0.7115 | 0.6944 | 0.7087 | 0.0171 | 0.0139
11/21/2002 | 0.7168 | 0.7100 | 0.7124 | 0.0081 | 0.0136
11/22/2002 | 0.7265 | 0.7120 | 0.7265 | 0.0145 | 0.0136
11/25/2002 | 0.7265 | 0.7098 | 0.7098 | 0.0167 | 0.0138
11/26/2002 | 0.7184 | 0.7110 | 0.7184 | 0.0086 | 0.0135
11/27/2002 | 0.7280 | 0.7200 | 0.7228 | 0.0096 | 0.0133
12/2/2002 | 0.7375 | 0.7227 | 0.7359 | 0.0148 | 0.0134
12/3/2002 | 0.7447 | 0.7310 | 0.7389 | 0.0137 | 0.0134
12/4/2002 | 0.7420 | 0.7140 | 0.7162 | 0.0280 | 0.0141
12/5/2002 | 0.7340 | 0.7207 | 0.7284 | 0.0178 | 0.0143

Расчет размера юнита на 06.12.2002 (используя значение N =0.0141 от 04.12.2002), будет таким:

N = 0.0141 Account Size = $1,000,000 Dollars per Point = 42,000 (контракт на 42,000 галлонов с ценами в долларах)

Unit Size = (0.01 x $1,000,000) / (0.0141 x 42,000) = 16.88

Поскольку невозможно торговать дробным количеством контрактов, эта величина должна быть усечена до 16 контрактов.
Вы можете спросить: "Как часто необходимо рассчитывать значение N и размер юнита?". Для Черепах таблица с размерами юнитов и значениями N по каждому из торгуемых фьючерсов составлялась каждый понедельник.

Важность размера позиции

Диверсификация - это попытка распределить риск по многим финансовым инструментам и увеличить возможности для проведения успешных сделок. Для правильной диверсификации нужно делать похожие, если не идентичные, ставки по различным инструментам.

Система Черепах использовала рыночную волатильность для измерения рисков, присущих каждому рынку. Затем мы использовали управление риском для построения позиций, имеющих постоянную величину риска (или волатильность). Это расширило полезный эффект от диверсификации и увеличило вероятность того, что прибыльные сделки перекроют ущерб от убыточных.

Заметим, что такой диверсификации трудно достигнуть, используя недостаточный торговый капитал. Рассмотрим вышеприведенный пример, если используется счет размером $100,000. Размер юнита будет единичным контрактом, поскольку 1.688 усекается до 1. Для небольших счетов эффективность диверсификации резко снижается.

Юниты как мера риска

Поскольку Черепахи использовали юниты как базовую единицу измерения позиции, и поскольку эти юниты учитывали риск волатильности, то юнит был мерой и риска позиции, и всего портфеля позиций. Черепахам дали правила управления риском, которые ограничивали количество юнитов, которые мы могли удерживать в любой момент времени, на четырех различных уровнях.

Фактически, эти правила контролировали общий риск, который мог выдержать трейдер, и эти ограничения минимизировали потери в течение продолжительных убыточных периодов, а также во время экстраординарных ценовых движений. Например, такое экстраординарное движение наблюдалось после краха фондового рынка в октябре 1987г. Федеральный резервный банк США резко снизил процентные ставки для поддержки доверия к рынку акций. Черепахи стояли в длинных позициях по евродоллару и казначейским облигациям. Потери на следующий день были огромными. В некоторых случаях от 20% до 40% от величины торговых счетов было потеряно в один день. Но эти потери были бы выше без ограничений на размер позиции.

Лимиты были такие:

Уровень | Тип | Макс.количество юнитов
1 | Один рынок | 4 юнита
2 | Хорошо коррелированные рынки | 6 юнитов
3 | Плохо коррелированные рынки | 10 юнитов
4 | Одно направление | 12 юнитов

Один рынок - максимум 4 юнита на рынок.

Хорошо коррелированные рынки - для хорошо коррелированных рынков могло быть максимум 6 юнитов в одном направлении (т.е. 6 юнитов на покупку или 6 на продажу). Хорошо коррелированными рынками являются: мазут и сырая нефть; золото и серебро; швейцарский франк и дойчмарка; казначейские обязательства и евродоллар и т.п.

Плохо коррелированные рынки - для плохо коррелированных рынков могло быть максимум 10 юнитов в одном направлении. Плохо коррелированными рынками являются: золото и медь; серебро и медь, и многие комбинации зерновых, которые Черепахи не могли торговать из-за ограничений в размерах позиций.

Одно направление - Общее максимальное количество юнитов в одном направлении (длинном или коротком) было 12 юнитов. Таким образом, теоретически можно было иметь 12 юнитов в длинном и 12 юнитов в коротком направлении одновременно.


Рынки: - Чем торговали Черепахи

Черепахи торговали фьючерсными контрактами на наиболее известных товарных биржах США. Так как мы торговали миллионами долларов, мы не могли торговать на рынках с дневным оборотом всего несколько сот контрактов, иначе бы наши ордера двигали бы рынок и было бы сложно входить и выходить из позиции, не получая больших убытков. Черепахи торговали только на наиболее ликвидных рынках. Вообще, Черепахи торговали на всех ликвидных рынках США, кроме рынков зерна и мяса. Так как Richard Dennis уже торговал на своем счете, он не мог нам позволить торговать зерном для него из-за превышения граничного размера позиции на бирже.
Мы не торговали мясом из-за коррупции трейдеров в торговой яме. Через несколько лет после расформирования группы Черепах ФБР провело операцию в чикагской торговой яме по мясу и предъявило обвинение многим трейдерам в манипулировании ценами и других формах коррупции.

Ниже приведен список фьючерсных рынков, на которых торговали Черепахи:

Chicago Board of Trade

30 Year U.S. Treasury Bond
10 Year U.S. Treasury Note

New York Coffee Cocoa and Sugar Exchange
Coffee
Cocoa
Sugar
Cotton

Chicago Mercantile Exchange
Swiss Franc
Deutschmark
British Pound
French Franc
Japanese Yen
Canadian Dollar
S&P 500 Stock Index
Eurodollar
90 Day U.S. Treasury Bill

Comex
Gold
Silver
Copper

New York Mercantile Exchange
Crude Oil
Heating Oil
Unleaded Gas

Черепахам дали свободу действий относительно выбора финансовых инструментов из этого списка. Однако, если трейдер принял решение не торговать на определенном рынке, то он не должен был торговать не этом рынке вообще. Мы не должны были торговать на рынках непоследовательно.


Стопы

Есть такое выражение: "Есть старые трейдеры; и есть отважные трейдеры;Но нет старых отважных трейдеров". Трейдеры, которые не используют стопов, становятся банкротами.

Черепахи всегда использовали стопы. Для большинства людей намного проще цепляться за надежду, что убыточная сделка обернется прибыльной, чем просто избавиться от убыточной позиции и признать, что эта сделка не сработала.
Давайте проясним одну вещь. Избавление от убыточной сделки очень критично. Трейдеры, не урезающие убытков, не будут успешными в долгосрочной перспективе.

Почти все примеры торговли, которая вышла из-под контроля и подвергла опасности целые финансовые институты, такие как Barings, Long-term Capital Management и другие, связаны со сделками, которым было позволено развиться в огромные убытки, потому что они не были закрыты, когда убытки были еще маленькими. Самая важная вещь в ограничении своих потерь - это заранее определить точку, где вы будете выходить, до того, как вы откроете позицию. Если рынок подойдет к вашей цене, вы должны выходить.

Отклонение от этого метода приведет в конце концов к бедствию.

Стопы Черепах

Наличие стопов не означает, что у Черепах всегда были реальные стоп-ордера, размещенные у брокеров. Поскольку позиции у Черепах были довольно большими, мы не хотели выдавать наши позиции или торговые стратегии размещением стоп-ордеров у брокеров. Вместо этого, мы имели определенную цену, достижение которой заставляло нас выходить из позиции или лимитным, или рыночным ордером. Эти выходы не подлежали обсуждению. Если определенный товар торговался по цене стопа, то позиция закрывалась каждый раз, без исключений.

Размещение стопов

Черепахи размещали свои стопы, основываясь на риске позиции. Ни одна сделка не могла подвергаться риску более 2%. Так как движения цены на 1N представляло 1% счета, то максимальный стоп, который позволял 2%-ый риск, был равен 2N. Стопы Черепах устанавливались на 2N ниже входа в длинные позиции и на 2N выше входа в короткие позиции. Для того, чтобы сохранить минимальным риск общей позиции, если добавлялись юниты, то стопы для более ранних юнитов поднимались на 1/2 N. Это означает, что все стопы для всей позиции размещались на расстоянии 2N от самого последнего добавленного юнита. Однако, в случае, когда последние юниты были размещены на большем расстоянии или из-за быстрого рынка, вызывающего проскальзывания, или из-за гэпа на открытии, стопы будут отличаться.

Например:

Сырая нефть N = 1.20 55-дневный прорыв = 28.30

 | Входная цена | Стоп
Первый юнит | 28.30 | 25.90

 | Входная цена | Стоп
Первый юнит | 28.30 | 26.50
Второй юнит | 28.90 | 26.50

 | Входная цена | Стоп
Первый юнит | 28.30 | 27.10
Второй юнит | 28.90 | 27.10
Третий юнит | 29.50 | 27.10

 | Входная цена | Стоп
Первый юнит | 28.30 | 27.70
Второй юнит | 28.90 | 27.70
Третий юнит | 29.50 | 27.70
Четвертый юнит | 30.10 | 27.70

Случай, когда 4-й юнит был добавлен по более высокой цене из-за того, что рынок открылся с гэпом по 30.80:

 | Входная цена | Стоп
Первый юнит | 28.30 | 27.70
Второй юнит | 28.90 | 27.70
Третий юнит | 29.50 | 27.70
Четвертый юнит | 30.80 | 28.40

Альтернативная стратегия стопов

Черепахам была рассказана альтернативная стратегия стопов, которая приводила к большей прибыльности, но которую было труднее исполнять, потому что она испытывала большее количество убыточных сделок, что выливалось в низкий win/loss ratio (коэффициент отношения прибыльных сделок к убыточным). Эту стратегию мы назвали Пила (Whipsaw). Вместо принятия 2%-го риска на каждой сделке, стопы размещаются на расстоянии ? N для полупроцентного риска. Если данный юнит был выбит стопом, этот юнит повторно вводился в рынок, если рынок достигал начальной цены входа. Несколько Черепах торговали этим методом с хорошим успехом. Стратегия "Пила" имеет также дополнительное преимущество - она не требует перемещать стопы для предыдущих юнитов при добавлении новых, поскольку общий риск никогда на превысит 2% для четырех юнитов.
Например, используя стратегию "Пила", стопы для сырой нефти будут такие:

Сырая нефть N = 1.20 55-дневный прорыв = 28.30

 | Входная цена | Стоп
Первый юнит | 28.30 | 27.70

 | Входная цена | Стоп
Первый юнит | 28.30 | 27.70
Второй юнит | 28.90 | 28.30

 | Входная цена | Стоп
Первый юнит | 28.30 | 27.70
Второй юнит | 28.90 | 28.30
Третий юнит | 29.50 | 28.90

 | Входная цена | Стоп
Первый юнит | 28.30 | 27.70
Второй юнит | 28.90 | 28.30
Третий юнит | 29.50 | 28.90
Четвертый юнит | 30.10 | 29.50

Преимущества стопов системы Черепах

Поскольку стопы Черепах основаны на N, они учитывают волатильность рынков. Более волатильные рынки имеют более широкие стопы, но они также имеют меньше контрактов в одном юните. Это уравнивает риски по всем входам и приводит к лучшей диверсификации и более робастному управлению риском.


Тактика.

Остались еще некоторые детали, которые влияют на прибыльность торговли по Системе Черепах.

Входные ордера

Как было упомянуто выше, Richard Dennis и William Eckhardt советовали Черапахам не использовать стопов, размещая ордера. Нам советовали следить за рынком и ставить ордера, когда рынок достигал нашей стоп-цены.

Нам также говорили, что лучше размещать лимитные ордера вместо рыночных. Потому что лимитные ордера давали шанс для лучшего исполнения и меньшего проскальзывания, чем рыночные. Обычно цена совершает небольшие случайные колебания. Идея использования лимитных ордеров заключается в размещении ордера (на покупку) у нижнего края этих движений вместо размещения рыночного ордера.

Лимитный ордер не будет двигать рынок, если это ордер небольшой, и почти всегда будет двигать его меньше, чем рыночный, если ордер большой.

Требуется некоторая сноровка для определения лучшей цены для лимитного ордера, но на практике вы сможете получать лучшее исполнение по лимитным ордерам, расположенным вблизи рынка, чем по рыночным.

Быстрые рынки

Иногда рынок движется очень быстро, и если вы разместили лимитный ордер, он просто может быть не исполнен. Во время быстрого движения рынок может продвинуться на тысячи долларов на контракт всего за несколько минут. В таких случаях Черепахам советовали не паниковать, а подождать с размещением ордера, пока рынок не стабилизируется. Большинство начинающих трейдеров находят это сложным для выполнения. Они паникуют и размещают рыночные ордера. Они постоянно делают это в самое худшее время и часто заключают сделки по худшей цене дня.

На быстром рынке ликвидность временно уменьшается. В случае быстрого подъема рынка, продавцы прекращают продажи и они не будут ее возобновлять, пока рост цены не остановится. При этом сценарии аски значительно поднимаются, и спред между бидом и аском расширяется. Покупатели теперь вынуждены платить намного большую цену, в то время как продавцы продолжают поднимать цены и цена в конце концов движется так далеко, что вовлекает в рынок новых продавцов, заставляя цену стабилизоваться и часто даже откатиться назад. Рыночные ордера, размещенные на быстром рынке, обычно исполняются по самой высшей цене как раз в точке, где цены начинают стабилизироваться.

Черепахи ожидали пока не появятся признаки по крайней мере временного отката цены перед размещением ордеров, и это часто приводило к лучшему исполнению, чем это можно было сделать рыночным ордером. Если рынок стабилизировался за пределами нашей стоп-цены, мы выходили из рынка, но делали это без паники.

Одновременные входные сигналы

Бывали дни, когда на рынках были небольшие движения и мы занимались только отслеживанием открытых позиций, не размещая ни одного нового ордера. Бывали дни, когда сигналы возникали один за другим через несколько часов. В этом случае мы выставляли ордера в порядке поступления сигналов. Но были дни, когда казалось, что все происходит одновременно, и мы увеличивали количество открытых позиций с нуля до максимально допустимого предела за 1-2 дня. Часто этот бешеный ритм усиливался многочисленными сигналами на коррелированных рынках. Особенно когда рынки открывались с гэпом, генерируя входной сигнал. При открытии можно было одновременно получить сигналы по сырой нефти, мазуту и неэтилированному бензину. Что касается фьючерсных контрактов, очень часто возникали входные сигналы на одном и том же рынке по контрактам с разными месяцами исполнения.

Покупай силу - продавай слабость

Если сигналы приходят одновременно, мы всегда покупали на самом сильном рынке и продавали на самом слабом рынке в группе. Мы всегда входили в один рынок одним юнитом. Например, вместо одновременной покупки февральских, мартовских и апрельских фьючерсов на мазут мы выбирали один, самый сильный контракт, который имел достаточный объем и ликвидность. Это очень важно! Внутри коррелированной группы, лучшая длинная позиция - на самом сильном рынке (который всегда превосходит более слабые рынки в той же группе). И наоборот, самые большие прибыльные сделки в короткую сторону возникают на наиболее слабых рынках внутри коррелированной группы.

Черепахи использовали различные способы измерения силы и слабости рынков. Простейший и наиболее употребительный - это просто посмотреть на графики и визуально определить, какой из них "выглядит" сильнее или слабее. Некоторые определяли, сколько N прошла цена после прорыва и покупали на том рынке, где цена продвинулась на большее расстояние (в единицах N).
Другие вычитали цену 3-месячной давности из текущей цены и потом делили на текущее N для нормализации. Самые сильные рынки имели наибольшие значения, самые слабые - наименьшие. Любой из этих подходов работает хорошо.

Переход на контракт с другим сроком исполнения

Когда истекает фьючерсный контракт, нужно учитывать два главных фактора при переходе на контракт с более отдаленным сроком исполнения.

Во-первых, бывает, что по контракту на ближайший месяц наблюдается хороший тренд, а по более отдаленному контракту - нет. Так что не переходите на новый контракт, пока текущий контракт дает лучший результат.

Во-вторых, на другой контракт нужно переходить до того, как объем и открытый интерес по истекающему контракту сильно упадут. Насколько сильно - это зависит от размера юнита. Как правило, Черепахи переключались на новые контракты за несколько недель до истечения, если только открытый контракт не давал значительно лучших результатов, чем более отдаленный.

Заключение

Таковы правила полной торговой системы Черепах. Они не очень сложные, но знание этих правил не сделает вас богатыми. Вы должны быть способны выполнять их.

Системе Черепах очень сложно следовать, потому что ее результат зависит от схватывания относительно нечастых больших трендов. Как результат, многие месяцы могут пройти между прибыльными периодами, иногда год или два. В течение этих периодов можно засомневаться в системе и прекратить выполнение ее правил. Многие Черепахи в попытке добиться сокращения риска торговой системы, слегка изменяли правила, что привело к противоположному эффекту.

Чтобы увеличить уровень доверия, вам нужно следовать правилам системы, является ли она системой Черепах или любой другой системой. Вы лично должны провести расчеты на исторических данных. Недостаточно услышать от других, что система работает. Недостаточно прочитать итоги исследований, проведенных другими. Вы должны сделать это сами.